Major Outage for Carbonite Server Backup
Incident Report for Carbonite Product Status Page
Resolved
This incident has been resolved.
Posted Oct 22, 2020 - 10:51 EDT
Update
We are continuing to investigate this issue.
Posted Oct 22, 2020 - 10:01 EDT
Investigating
We are currently experiencing a service outage impacting the US WEST Carbonite Server Backup Portal.

The incident is currently under investigation.
Posted Oct 22, 2020 - 10:00 EDT
This incident affected: Carbonite Server Backup (Carbonite Server Backup US West).