Carbonite Backup for M365 - Degraded Performance
Incident Report for Carbonite Product Status Page
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 11:50 EDT
Update
We are continuing to investigate this issue.
Posted Oct 20, 2021 - 11:50 EDT
Investigating
The Backup for M365 service is currently experiencing degraded performance.  Our team is investigating and working on a speedy resolution.
Posted Oct 19, 2021 - 14:46 EDT
This incident affected: Carbonite Backup for Microsoft 365 (Carbonite Backup for Microsoft 365 France Central (Paris)).